Runtime error: access denied

Mar 5, 2008 at 1:08 AM
Edited Mar 5, 2008 at 1:10 AM
Hi,

This concerns v. 1.1.

After downloading, unpacking and moving some files, Step 1 of the Quick Start Guide went well. I indeed got the empty slideshow as in Figure 1 of the Start Guide. But as I subsequently inserted "new SlideShow.XmlConfigProvider()" in the inline script tag, as prescribed in Step 2, I got a runtime error alert: Line 8, Access denied.

Completing all steps nonetheless is no cure.

How do I solve this?

- Frank
Mar 9, 2008 at 6:42 AM
I got the same problem. Follow the below step to get it resolved

1. Copy all the js files from debug folder and have them in the folder which contains your slideshow html.
2. Paste the following script tags in the <head> of html
<script type="text/javascript" src="SlideDescription.js"></script>
<script type="text/javascript" src="NavigationTray.js"></script>
<script type="text/javascript" src="SlideViewer.js"></script>
<script type="text/javascript" src="Button.js" ></script>
<script type="text/javascript" src="ThumbnailViewer.js"></script>
<script type="text/javascript" src="AlbumViewer.js"></script>
<script type="text/javascript" src="Transition.js"></script>
<script type="text/javascript" src="DataProvider.js"></script>
3. Remove the progress bar module from configuration file.
4. Also remember to have correct names of the images in the data.xml file. The one given in the pdf/usermanual doc doesnt exist there. You need to change it.

Try out above three steps. If you are using IE, it will not work locally. I still haven't digged out the reason but it does work when you try browsing it as a website from IIS. Also it works locally when you us firefox.

Thanks and Regards,
Amit Bajaj
Mar 13, 2008 at 11:38 PM
Thanks, Amit.

I've found an alternative that actually serves my goal better than SlideShow does (even though it is not as fancy), but I will certainly try to get SlideShow working sometime. And I will let you know then how things worked out.

- Frank
Mar 13, 2008 at 11:38 PM
Edited Mar 13, 2008 at 11:39 PM
Sorry, clicked the button twice.
Apr 28, 2010 at 8:26 PM

Hi Amit and Frank,

Can you please give me a hand with my SlideShow learning curve? I spent a week trying to figure things out myself, but I keep receiving one configuration error after I fix the previous error and I thought it was about time to get help. As I was searching through this forum, I found out that Frank had the same experience, although he has moved on to another option, and it seems that Amit made his SlideShow work.

My SlideShow page is located at http://www.sharecircle.org/newindex/nowrotate/newslideshow/mikeswanson/default.htm. In fact, as you will see, I merely used the files and CODE Mike Swanson put together for his SlideShow at http://www.mikeswanson.com/Slide.Show/default.htm

As you will see, Mike's SlideShow works with no problems. However, I canno't get it to work using the same very code! I keep getting the following:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6.4; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 1.1.4322; .NET CLR 3.5.30729; .NET CLR 3.0.30729; msn OptimizedIE8;ENUS)
Timestamp: Wed, 28 Apr 2010 19:16:59 UTC


Message: Undefined property: viewerBackgroundFill
Line: 71
Char: 4
Code: 0
URI: http://www.sharecircle.org/newindex/nowrotate/newslideshow/mikeswanson/SlideShow.js.

 

Here are the links to relevant files in my SlideShow folder: http://www.sharecircle.org/newindex/nowrotate/newslideshow/mikeswanson/Configuration.xml, http://www.sharecircle.org/newindex/nowrotate/newslideshow/mikeswanson/Data.xml, http://www.sharecircle.org/newindex/nowrotate/newslideshow/mikeswanson/Silverlight.js and http://www.sharecircle.org/newindex/nowrotate/newslideshow/mikeswanson/SlideShow.js

You can get/download all files related to my SlideShow in my Default.htm files at http://www.sharecircle.org/newindex/nowrotate/newslideshow/mikeswanson/ if that will help. Again, I did not configure anything else in any other files.

 Thank you, in advance!

Guerra