Configuring an alternate Data.xml file

Dec 14, 2007 at 1:28 PM
I am trying to set this up on my site but running into a snag. I see how I can configure an alternate config file:

new SlideShow.Control(new SlideShow.XmlConfigProvider({url:'SLSlideShowConfig.aspx'}));

I can see that SLSlideShowConfig is getting loaded but in that config file I want to specify a different data source. I am trying this, but it doesn't seem to work

<dataProvider type="XmlDataProvider">
<option name="url" value="/photos/SLPhotos.ashx" />
</dataProvider>

if I visit SLPhotos.ashx directly I get the following:

<data transition="CrossFadeTransition">
<album title="Animals" description="Photos of several animals (cross fade transition)" image="/photos/storage/1000.4.41.bayon.jpg">
<slide title="Monterey Aquarium Exhibit — Jellies: Living Art" description="Photo taken by Alan Le" image="/photos/storage/1000.4.41.bayon.jpg" thumbnail="/photos/storage/1000.4.41.bayon.jpg"/>
<slide title="My Cat" description="Photo taken by Scott Stanfield" image="/photos/storage/1000.4.41.bayon.jpg" thumbnail="/photos/storage/1000.4.41.bayon.jpg"/>
</album>
</data>

Its mostly a copy paste from your sample. Should I be getting any feedback that it is finding my ashx file? I get no errors, just a grey box where the photos should be.
Dec 14, 2007 at 1:35 PM
DOH! My dataprovider element was under modules rather than under configuration....seeing pictures now. If only I had noticed that 4 hours ago.
Coordinator
Dec 15, 2007 at 3:49 AM
Glad it worked out! I checked your site and it looks like your photos page still has a script tag referencing "localhost", however, which is causing the slideshow to break for us. Please let us know when it's fixed so we can check out your slideshow. Thanks!
Jan 7, 2008 at 7:27 PM
Well, I fixed it a couple weeks ago...now I need to upload some better photos...